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Welcome to Security Logger

Security Logger for Netscreen is a SYSLOG server that collects SYSLOG messages from a Netscreen firewall.  These messages are then sorted in to two classifications, traffic records or message records and written to Microsoft Access databases.  

Once written to database, you can use Microsoft Access or other database administration tools to run queries on the stored data. From these queries, you can create reports on any number of things.


Getting Started 

       Thank you for evaluating Security Logger for Netscreen. 

Once the product is installed, there are two steps needed to start collecting SYSLOG messages. The first step is to configure Security Logger to listen for incoming  SYSLOG messages. To do this, go to Options -> IP/Port Settings. Enter the IP address and port you want the Security Logger to use for incoming SYSLOG messages.  The default SYSLOG port is UDP 514.  Once you have entered in the IP address and port, click on OK. Next, select the Action -> Start to start Security Logger.

The second step is to configure the Netscreen firewall to send traffic and/or message records to Security Logger.  To configure the Netscreen to send message records, connect to it with the Web UI. Once logged in, go to Admin -> Syslog. Enable SYSLOG messages by selecting the “Enable Syslog Messages” check box. For the “Syslog Host Name” field, enter the IP address of the Security Logger. Click on Apply. You should start to see message records show up in the Log Processing Messages window on Security Logger.

To enable the Netscreen to send traffic logs to Security Logger, click on the “Include Traffic Log” check box in the Netscreen Web UI under Admin -> Syslog. Netscreen traffic logs are specified per policy. So to have the Netscreen collect traffic logs, you need to edit the policies and select “Enable Logging” for each policy that you want the Netscreen to log. 

That’s it. Security Logger should now be collecting records. menu_help
Main Screen

The main screen of the application shows you up to date information on records processed, errors logged, record handling statistics, and SYSLOG IP and port information.
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Error Log Settings: If configured, this displays statistics on the error log file and number of errors logged. This can be changed in the Options -> Log Errors to File menu option.

SYSLOG Settings: This displays the IP address and port that Security Logger is listening on for incoming SYSLOG messages. This can be adjusted in the Options ->IP/Port Settings menu option.

Forward Traffic Record Settings: If configured, this displays the IP address and number of traffic records sent to the forward SYSLOG server. This can be configured in the Options->Record Handling menu option.

Forward Message Record Settings: If configured, this displays the IP address and number of message records sent to the forward SYSLOG server. This can be configured in the Options->Record Handling menu option.

Application Messages: This displays startup and shutdown information for the Security Logger application.

Recover Processing Messages: This displays the status of the recovery and DNS update processes once started.  It will also notify you when the processes have finished.

Log Processing Messages: This displays the number of traffic and message records processed.

File menu commands
     The File menu offers the following commands:

	Save ConfigurationHID_FILE_SAVE
	Saves the current Security Logger configuration.

	ExitHID_FILE_EXIT
	Exits the Security Logger application.


Options menu commands
   The Options menu offers the following commands:

	IP/Port SettingsHID_IPPORT
	Configures the IP address and port for the SYSLOG service.

	Log Errors to FileHID_OPTLOG
	Configures Security Logger to log events to a file.

	Clear CountersHID_CLEAR
	Clears the message and/or traffic record counters.

	Record HandlingHID_FORWARD
	Configures Security Logger to store traffic and/or message records locally.

Can also set Security Logger to forward traffic and/or message records to another SYSLOG server.


Action menu commands
The Action menu offers the following commands:

	StartHID_STOPDB
	Starts database collection.

	StopHID_STARTDB
	Stops database collection.



	Pause/RestartHID_RECOVERDB
	Pauses/Restarts database collection.

	Recover HID_RECOVERDB
	Recovers records stored in a file and writes them to

database.


Update DNS menu commands
The Update DNS menu offers the following commands:

	Update DNS TableHID_STOPDB
	Updates the name resolution table.

	DNS Table SettingsHID_STARTDB
	Configure DNS settings.



	Clear DNS TableHID_RECOVERDB
	Clear the name resolution table.


Help menu commands
The Help menu offers the following commands, which provide you assistance with this application: 

	Help Topicsmain_index
	Offers you an index to topics on which you can get help.

	AboutHID_LVIEW
	Displays the version number and license status of Security

Logger.

	License UpdateHID_LUPDATE
	Updates the license status from evaluation to a limited or full

license.


Save Configuration command (File menu)
Use this command to save the current configuration of Security Logger. The saved information

Includes IP/Port, event log handling, record handling and pause database collection settings.

Exit command (File menu)
Use this command to end your Security Logger session.  You can also use the Exit button in

the main window.

IP/Port Settings command (Options menu)
Lets you configure the IP address and port Security Logger should listen for incoming SYSLOG messages.
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Log Errors to File command (Options menu)
Use this command to have the Security Logger application write events to a specified file. 

Events include status and error messages. The file can be view with a text editor such as 

Notepad.

[image: image3.jpg]Settings [Tl

Log

¥ Log event messages to fle.

[CProgram FlesGecuntyLoggenErmors ot

e





Clear Counters command (Options menu)
Use this command to clear the message and traffic counters. This sets the counters back to 0.
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Record Handling command (Options menu)
Use this command to configure record handling options.
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Store message records to local database: This option tells Security Logger to store incoming SYSLOG messages that are classified as a message to the local database. If this option is not selected, then incoming SYSLOG messages that are classified, as messages will not be stored locally.

Forward message records to SYSLOG server: This option tells Security Logger to forward message records to another SYSLOG server.

Store traffic records to local database: This option tells Security Logger to store incoming SYSLOG messages that are classified as a traffic record to the local database. If this option is not selected, then incoming SYSLOG messages that are classified, as traffic records will not be stored locally.

Forward traffic records to SYSLOG server: This option tells Security Logger to forward traffic records to another SYSLOG server.

Start (Action menu)
Starts the database collection process.  Once started, Security Logger will listen on the configured SYSLOG IP and port for incoming messages.

Stop (Action menu)

Stops the database collection process. Once stopped, Security Logger will close the databases and no longer listen for incoming SYSLOG messages.

Pause/Restart (Action menu)
If the database collection is started, then selecting this option will allow you to pause it.  Once paused, the databases are closed and incoming SYSLOG messages are stored to the specified file.  To restart the database collection, simply click on it a second time. Once restarted, the databases are opened again and SYSLOG messages are written to them.
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Recover (Action menu)
This option allows you to recover SYSLOG messages from a file used in the Pause process. These records are recovered while the Security Logger is listening for incoming messages. This way, you do not lose any records.
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Help About command (Help menu)

Use this command to view the current license status and version of the Security Logger application..
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Update License command (Help menu)

Use this command to update the license of the Security Logger application. Please see the Help->About command for information on contacting Adimpleo for an updated license.

Update DNS Table command (DNS Table menu)

Updates the name resolution table.  Security Logger will attempt to resolve source and/or destination IP addresses in to fully qualified domain names.  

DNS Table Settings command (DNS Table menu)

Use this command to adjust the DNS name resolution options.
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Resolve source IP addresses: This option tells Security Logger to resolve source IP addresses.

Resolve destination IP addresses: This option tells Security Logger to resolve destination IP addresses.

Filter by direction: This option tells Security Logger to only resolve records that match the direction selected.

Filter by firewall: This option tells Security Logger to only resolve records that match the firewall selected.

Include HOSTS file: This option tells Security Logger to use a HOSTS file when resolving IP addresses in to names. If this option is selected, Security Logger will attempt to use the name specified in the HOSTS file before trying to resolve it by a DNS server. The HOSTS file format is the same as the Windows HOSTS file.

Apply HOSTS file to source IP addresses: This option tells Security Logger to use the HOSTS file data on source IP addresses.

Apply HOSTS file to destination IP addresses: This option tells Security Logger to use the HOSTS file data on destination IP addresses.

Clear DNS Table command (DNS Table menu)

Clears the name resolution table.

Frequently Asked Questions

1. Does Security Logger have to stay running to collect SYSLOG messages?

Yes.  The only time Security Logger is listening for incoming SYSLOG messages is when it is started.

2. What kinds of errors are logged?

Errors occur when there is an issue with writing to the database or starting the application. If you start to see a bunch of errors being counted, check the error log file to see what is happening.

3. How do I pause database collection?

Database collection can be paused by going to Action -> Pause/Restart. Enter in the file that you want Security Logger to use to store records. Click on OK. Within 5 seconds, Security Logger will close the databases and write records to file.

4. Why would I want to pause database collection?

You would want to pause database collection if you need to perform database maintenance. This includes removing records or performing a compact/repair on the databases. Once you have finished performing database maintenance, click on Action -> Pause/Restart to start database collection.

5. How do I recover records stored to file?

You can do this by going to Action->Recover. Enter in the name of the file used to store the records and click on OK. The records will start to be recovered and written to database. You will see recover status messages in the Recover Processing Messages section.


6. Why does the recovery process appear slow?

The recovery process occurs while Security Logger is collecting new SYSLOG messages.  This was done to limit the possibility of lost SYSLOG messages as  much as possible. Be patient, the logs will be recovered.

7. What is a traffic and message record?

Traffic records are records that contain detailed information on traffic passing through the Netscreen. In Netscreen terms, these are all of the records that you would see in the Netscreen Web UI under Log -> Traffic Log. Message records are records that include general events (Log -> Event Log) and specific alarms (Alarm -> Event Alarm).

8. Why do the databases grow and grow?

Unfortunately, this is just how Jet and ODBC work. We have tried to minimize the growth of the databases by normalizing them as much as possible.  If the databases start to become too large, you have a few options. The first option is to pause the database collection and run a compact/repair on the databases. If the databases are still too large, you may want to archive the large databases and replace them with fresh smaller ones. To do this, stop the Security Logger application. Move the large databases (by default these are stored in the <Install Directory>\Data folder). Replace them with the blank ones stored in the <Install Directory>. Open the application and start Security Logger.

9. I want to run Security Logger on one machine but house the databases on a second machine. How do I do that?

Security Logger uses ODBC to write to the databases.  This means that it uses User DSNs to specify which databases to use. By default this will be in the <Install Directory>\Data folder. To change the location, you will need to move the databases and adjust the DSN settings. Once you have a copy of the databases on the desired server, stop Security Logger. Then, go to My Computer -> Control Panel -> Administrative Tools-> DataSources(ODBC) (My Computer -> Control Panel -> DataSources(ODBC) in all but Windows 2000). Click on the User DSN tab. The two DSNs that Security Logger uses are Traffic_DB and Message_DB. To change the file location of these DSNs, highlight one and click on the Configure button. Under the Database section, click on Select. Change the database location as desired. Click on OK. You will need to do this process for both the Message_DB and the Traffic_DB DSNs. Once you have changed the database location settings, you can open Security Logger and start it.

Remote Installation

There may be times when you want to run the Security Logger application on one machine and house the databases on another machine.  Editing the ODBC DSN      settings can do this. However, the steps will be different if you are adjusting the DSNs for Access databases or SQL databases.

      Adjusting the DSNs for Access Databases

Security Logger uses two DNSs for writing data to the Access databases. These are the Traffic_DB and Message_DB. You will need to edit both of them. To adjust the DSN setting for MS Access databases, you will need to complete the following steps.

1. Go to My Computer->Control Panel->Administrative Tools->Data Sources(ODBC) (My Computer->Control Panel->Data Sources ODBC in operating systems other than Windows 2000.

2. Click on the User DSN tab.

3. Highlight the Traffic_DB DSN and click on Configure.

4. Click on Select under the Database section. Use the pull down to point to the TrafficLog.MDB database. Click on OK to select the database. Click on OK to exit the DSN configuration.
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5. Highlight the Message_DB DSN and click on Configure.

6. Click on Select under the Database section. Use the pull down to point to the MessageLog.MDB database. Click on OK to select the database. Click on OK to exit the DSN configuration.

Adjusting the DSNs for SQL Databases

Please see the document Configuring SQL Server 2000 for Security Logger for complete details.

